Configuration du hostname sur un réseau

Bonjour,

Je viens d’installer ma station de travail sous centos7.
Je pensais que le domaine était défini par le server DNS de mon réseau, ainsi j’ai mis simplement le nom de ma machine machinexx.
Par contre je n’arrive pas à voir ma machine sur le réseau par son nom.
Finalement les IT m’ont dit qu’il fallait que je mettes le domaine dans le fichier hostname, mais je n’arrive toujours pas à rendre visible ma machine depuis une autre à l’intérieur de ce réseau.

J’ai bien une adresse ip, mais ma machine n’est pas identifiable par son nom (court ou long)

Voici mes fichiers de configuration:

/etc/hostname
machinexx.dom.ca

/etc/hosts (j’ai essayé sans, rajouté devant, derrière le nom de la machine, dans différents ordres :frowning: )
127.0.0.1 machinexx.dom.ca machinexx localhost.localdomain localhost localhost4.localdomain4 localhost4
::1 machinexx.dom.ca localhost6.localdomain6 localhost6

/etc/sysconfig/network (j’ai fait plusieurs tests sans rien ou avec mon nom de machine)
HOSTNAME=machinexx.dom.ca

$ hostname -s
machinexx

$ hostname -a (pourquoi y a pas le machinexx.dom.ca dans cette liste ?)
machinexx localhost.localdomain localhost localhost4.localdomain4 localhost4 localhost6.localdomain6 localhost6

$ hostname -A
machinexx

$ hostname -f
machinexx.dom.ca

$ domainname
dom.ca

J’ai passé une journée à chercher une solution, mais je ne la trouve pas, je me demande si le dns n’a pas gardé mon nom de machine sans le domaine

/etc/resolv.conf
search dom.ca
nameserver 10.162.8.10
nameserver 10.162.8.11

/etc/nsswitch.conf (j’avais la première ligne, j’ai essayé la seconde :frowning: )
[…]
hosts: files mdns4_minimal [NOTFOUND=return] dns myhostname
hosts: files dns [NOTFOUND=return] dns myhostname

nslookup machinexx
;; Got SERVFAIL reply from 10.162.8.10, trying next server
Server: 10.162.8.11
Address: 10.162.8.11#53

** server can’t find machinexx: SERVFAIL

si je prends l’ip de ma machine, je vois son nom mais pas le fqdn, je me demande si c’est pas ça le pb ? Comment ce nom arrive sur le dns ?

nslookup 10.164.73.59
Server: 10.162.8.10
Address: 10.162.8.10#53

59.73.164.10.in-addr.arpa name = machinexx.

Voilà si vous avez un peu de temps pour m’aider à tester des trucs et répondre à mes questions pour identifier le problème ce serait vraiment apprécié.

Merci !

Marl

Pour information j’avais suivi la réponse de cette page, mais sans succes
stackexchange

N’ayant pas d’expérience concrète avec RedHat/CentOS, je ne peux pas parler d’expérience malheureusement, mais une recherche rapide sur le Web m’indique quelques procédures concernant le hostname et le FQDN :

En espérant que ces pistes aident… :slight_smile:

Il me semble que tu cherche à régler dans la configuration de ta station de travail un probleme qui se trouve ailleurs. Dans la plupart des situations la reconnaissance et la configuration des machines sur un réseau se fait par DHCP. Le routeur a le serveur, et chaque appareil connecté est un client. Visiblement cela ne marche pas chez toi.

  • Peux tu te connecter facilement avec d’autres appareils sur ton réseau ? Alors le serveur DHCP du routeur est ok, sinon regardes là .
  • Ton appareil (sans les configurations particulières que tu as essayé) peut il se connecter facilement sur d’autres réseaux. Si oui, ton client DHCP marche. Si non, il faut faire tourner un client DHCP sur ta machine. Pour centros … ce n’est pas moi qui t’y aiderai, mais si tu cherches dans cette voie, tu devrais trouver.

Bonjour @xavier ,
Pour répondre a tes questions :
1- oui je pense être reconnue sur le réseau. Par exemple, j’ai accès a l’intranet et aux imprimantes sur le réseau. Je suis aussi capable de me connecter à ma machine par ssh par exemple à partir d’une autre machine branchée sur le réseau mais seulement en utilisant son IP et non son shortname ou son fqdn, c’est ce que j’aimerai arriver à faire.
2- oui j’ai accès à d’autres réseaux extérieurs, par exemple des centres de calculs.
Merci !
Marlene

Bonjour @mathieugp,

Désolé je n’ai pas eu la notification pour ton message ! Je le lis à l’instant. Merci des suggestions.

Pour ton premier lien, est-ce que cette procédure est valide si le réseau attribue des IP fixes seulement ou cela fonctionne également si les IP sont flottantes ?

Pour ton second lien oui j’ai déjà utilisé cet outils hostnamectl.

Dans le premier lien ils passent l’option --static, cela je ne l’ai pas fait. En fait je ne sais pas si mon IP est fixe ou statique. C’est pour cela que je n’ai pas mis dans mon /etc/hosts la ligne avec l’adresse ip courante et le nom de machine. Peut-être que cela règlera le problème…