Création de formulaire avec formulaire.facil.services

Bonjour,

J’ai voulu créer un formulaire à l’aide du service facil du même nom. Hors, le site présente le service sans donner d’option de création ni de possiblité de connexion. Est-ce que quelqu’un voit ce qui m’a échappé?

Merci
Bonne journée!

Voir

1 « J'aime »

on pourrait virer le yakforms et rediriger vers CryptPad

2 « J'aime »

Versatile ce CryptPad, je n’avais pas remarqué ça, merci.

1 « J'aime »

Est-ce que c’est compliqué de changer, dans la page des Services FACiLes, le lien de formulaire.facil.services à formulaire.facil.services/user ou à ebauche.facil.services/form ? Ça permettrait d’arriver automatiquement à quelque chose de fonctionnel en attendant de savoir ce qu’on fait avec le service de formulaires. cc@mathieugp

Formulaire FACiLe est très utilisé. J’ai validé 14 nouveaux comptes d’utilisateur sur formulaire.facil.services juste le mois dernier. Yakforms est pas mal plus puissant que CryptPad Forms ou Nextcloud Forms. On pourrait pas vraiment remplacer par l’un ou l’autre dans l’état actuel.

Dans mes tests, je n’ai réussi à reproduire le problème rapporté ci-haut que sur Chrome sur le téléphone Android de mon travail. Impossible de le reproduire sur mon ordinateur de bureau ou mon ordinateur portable avec Firefox ou Chromium sur Debian ou Ubuntu.

Pour corriger le problème (qui est très mineur techniquement même s’il est gros du point de vue de l’expérience utilisateur), il faudra d’abord savoir exactement avec quels navigateurs/systèmes d’exploitation (et les versions) les boutons de la page d’accueil ne s’affichent pas correctement.

Possible que la piste proposée par renaudb ici soit utile, je n’ai pas regardé encore. J’espère trouver un trou pour regarder ça comme il faut très prochainement.

Je présume que le correctif devra être appliqué quelque part dans le code du thème Drupal pour yakforms.

Ça m’étonne. J’avais dans l’idée que t’étais le seul à voir les boutons parce que t’étais admin. Peut-être que les nouveaux utilisateurs ont découvert par eux-mêmes ou ont lu dans le forum qu’il faut ajouter /⁠user dans la barre d’adresse pour que ça marche.
Sur mon ordinateur de bureau, avec openSUSE Tumbleweed et Firefox, je ne voyais pas les boutons en juillet dernier, je ne les voyais pas en septembre et je ne les vois toujours pas en février 2024. Mon Firefox est rendu à 122.0. Même absence de boutons avec Chromium Version 121.0.6167.139 (Official Build, ungoogled-chromium) (64 bits).
J’ai aussi fait le test avec mon ordinateur portable (Debian 11) : pas de boutons avec Firefox 115.7.0esr.

Si quelqu’un d’autre que @mathieugp voit les boutons CRÉER UN COMPTE et SE CONNECTER quand il ou elle va sur la page d’accueil de Formulaire FACiLe, prière de nous indiquer comment vous y parvenez.

@antdesros C’est sûr que c’est pas parce que je suis connecté en tant qu’administrateur. J’ai testé sans être connecté, dans une fenêtre privée, avec Chromium et Firefox. Comme l’a écrit renaudb, les boutons sont toujours là avec tous les navigateurs, mais un bogue de CSS fait qu’ils ne sont pas affichés dans certaines conditions. Je peux reproduire la condition avec Chrome sur le tel Android de mon travail, donc j’ai en principe ce qu’il faut pour essayer de comprendre et corriger (ou contourner) le bogue.

Je ne fais rien de spécial, ça marchait déjà pour moi et ça marche toujours. Je n’ai pas de compte et je vois les 2 boutons Créer un compte et Se connecter avec Firefox et Chrome sur PopOS (ubuntu) avec i3 comme window manager - pas que ça devrait changer grand chose.

@antdesros peux-tu aussi partager une capture d’écran stp?

Ça fait des lunes, je dirais même, des comètes, que je n’ai pas touché à Drupal mais en regardant la source, je vois 2 endroits avec des boutons Créer/Connecter. Le bout de code suivant ne s’affiche pas mais l’autre (dans le header) est bien visible pour moi.

<div class="user-block-connect"><a href='https://formulaire.facil.services/user/register' class='btn btn-success btn-sm' role='button'>Créer un compte</a>&nbsp;&nbsp;&nbsp;&nbsp;<a href='https://formulaire.facil.services/user' class='btn btn-primary btn-sm' role='button'>Se connecter</a><br/><br/><div><a href='https://formulaire.facil.services/fonctionnalites' class='btn btn-default btn-sm' role='button'>Fonctionnalités</a> </div> </div></div class="user-block-connect">  </div>

Merci pour ta réponse.
Je peux bien mettre une capture d’écran, mais elle va être identique à celle de Marc.
Voici ma capture d’écran.

Est-ce que tu aurais des extensions susceptibles de cacher ce bloc? C’est vraiment étrange ce Heisenbug!

Aucune extension.
Comme on est au moins 5 à ne pas voir les boutons et que je suis un utilisateur quasiment lambda, j’aurais plutôt tendance à penser que c’est Mathieu et toi qui avez une configuration particulière sur vos navigateurs qui fait en sorte que vous voyez les boutons. Mon hypothèse est que les boutons n’apparaissent pas sur un Firefox par défaut.

En fait, j’ai tendance à garder les choses simples, pas trop custom. J’ai uBlock, que j’ai désactivé pour tester, même résultat.

Est-ce que tu vois les boutons sur Framaforms - Créez et diffusez vos formulaires facilement… ou https://sondage.sans-nuage.fr/ ?

Je suis très intrigué mais trop occupé en ce moment pour creuser davantage,


Le bouton Créer un formulaire ne semble pas apparaître sur Formulaire FACiLe. Je me demande si c’est voulu.

@antdesros Visiblement Framasoft et Sans Nuage ont pas utilisé le thème par défaut de Yakforms.

J’ai forcé l’affichage du bouton «Créer un formulaire» sur la page d’accueil (avec du CSS inline), mais pour les boutons «Créer un compte» et «Se connecter» en haut à droite, ça reste mystérieux… Une personne qui m’aidait à tester (Firefox sur Windows 10) m’a dit que c’était réparé de son bord après avoir changé la version de JQuery du thème Yakforms, mais sur le Android de ma job ça changeait rien.

En tout cas, à court terme y’a un gros bouton «Créer un formulaire» pour tout le monde maintenant. C’est déjà ça. :slight_smile:

3 « J'aime »

Je vois les boutons de mon côté si je désactive la protection contre le browser fingerprinting dans les paramètres de Brave. Les boutons fonctionnent dans Firefox et dans Google Chrome vanille.

1 « J'aime »

De mon coté, sur Windows, Macos ou Ubuntu, avec firefox safari duckduckgo, je voyais pas les boutons en haut. Mais voilà, ce nouveau bouton en milieu de page est un excellent workaround, merci!